You need to log in to create posts and topics.

EVC2 Beta Software

Hi,

supports the device also the

IR3521M ?

 

Quote from BlackRain85 on 2019-12-10, 05:13

Hi,

supports the device also the

IR3521M ?

 

It doesn't seem possible to support it. "High Speed (HS) I2C Serial" seems to refer to the SVI interface which has a voltage level of ~1.0V.

" The IR3521 supports the AMD SVI bus protocol and the AMD Server and desktop SVI wire protocol which are
based on High-Speed I
2C "

Quote from elmor on 2019-08-06, 01:46

New software uploaded, see the top post.

 

Quote from Luc Salmon on 2019-07-30, 04:55

Can we already use the hotwire feature? it's killing me to stare at this thing and not be able to use it hahaha

Yes, it works. Check the end of this video for an example: https://www.youtube.com/watch?v=ohMSwZRtA8o

  1. Measure resistance between FB and VOUT to get R1
  2. Measure resistance between FB and GND to get R2
  3. Measure the voltage at FB which should be = VREF
  4. Connect SRCx to FB
  5. Connect VINx to VOUT
  6. Enter R1/R2/VREF values under DAC1 in the EVC2 software
  7. You should now be able to modify the voltage. I'd recommend starting with a small positive value which would decrease the output voltage.

I've never had to use the feature, but i was modding my P5K Premium for VTT and saw it had 1MOhm to GND, and thought it might be a good opportunity to try this out, is the EVC capable of handling the uhm resistances required?

Quote from elmor on 2019-12-11, 15:22
Quote from BlackRain85 on 2019-12-10, 05:13

Hi,

supports the device also the

IR3521M ?

 

It doesn't seem possible to support it. "High Speed (HS) I2C Serial" seems to refer to the SVI interface which has a voltage level of ~1.0V.

" The IR3521 supports the AMD SVI bus protocol and the AMD Server and desktop SVI wire protocol which are
based on High-Speed I
2C "

So you are not sure ?

Quote from BlackRain85 on 2019-12-12, 09:39

So you are not sure ?

From the information in the datasheet it doesn't seem possible to support this controller, as it doesn't have a standard I2C/SMBus/PMBus interface.

Quote from Luc Salmon on 2019-12-12, 05:41

 

I've never had to use the feature, but i was modding my P5K Premium for VTT and saw it had 1MOhm to GND, and thought it might be a good opportunity to try this out, is the EVC capable of handling the uhm resistances required?

1Mohm doesn't sound correct, the feedback resistors are usually a few to a few tens of kiloohms.

New release 1.0.1.1b. No change to the software only the configuration files. Patches an issue where Loop 2 Manual would apply to Loop 1 on AMD systems for IR35201/Ir35204/IR35217/ASP1405I.

New release 1.0.1.1b. Fixed applying voltage in I2C and PMBus mode on IR3567B.

I'm struggling a bit with the Winbound W25Q32BV / ID:0xEF4016
Tried setting up everything by hand, but still have reading issues via SOIC8 clip

Tried the generic W25QxV one & the W25Q32FC/JV , with specified 4mb chip size - but it's still the same issue ~ empty file readout
It's an IntelME locked HM76 notebook 

Can you please doublecheck if the BV lineup is different and add these ones to the SPI_FLASH.xml

Spoiler
W25Q10B (128kB)
W25Q20BV (256kB)
W25Q40BV (512kB)
W25Q80BV (1MB)
W25Q16BV (2MB) 
W25Q32BV (4MB)
W25Q64BV/FV (8MB) 
W25Q128BV/FV (16MB)

Unsure if the software needs re'compiling or the issue is eddited user error
Tried to update the xml by myself but still no luck in getting a correct read-dump 

EDIT:
Apparently my issue is an SPI readout lockdown - test checked reading it out via SOIC8 clip and at the same time using fptw64 to get read access to it
(which errors normaly with "have no read access, need to modify descriptor to give access bla bla ~ know what to do when i can read & flash it) 
As either the export is 00 00 00 or FF FF FF - i have a suspicion, that i either need to read it out from another machine , while this one is not running
Or after i pinmod the board to gain access
Noticed, as the flashchip got "locked" while i read it out, showing on fptw that it didn't detect any chip - dev ID is identical to the W25Q32BV

So the chip is detected correctly, but the data is all 00 or FF? Are you using the SPI_BOOSTER for improved GPIO drive strength? https://www.elmorlabs.com/index.php/product/evc2n2-spi-booster-adapter/ (it can be ordered for free for existing customers, you can contact me if you need it). Do you have more information about this "SPI readout lockdown"?